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HES Z et son oA Lct

BigQuery ZEME |p (&M) cepo = BigQuery Z2EMEO| TR EHID
uct.

&l =& (M) MEiSt Z2, d 0| 0| UL A|ZF £ &
of F7+EILICEH

e 28 2xt (M) 8ol dlole HEE EElste Rkt
ZI2Me = B(\y)ol HEE TFE LT

kel (SM) dole &g F25t= AL ct 7|2™
SE ME2 YO|HIO|H &2 FEFLICE ME
2 82 x"dst= 2xts EE YL 7|
22 gEol s S E 2XHE RS2 2 A
S,

HZ! o|& Cll0|E{7} 2 E E|= Google Cloud Storage H{Z!

EHE=2 (&) Google Cloud Storage ZH2| F2 ]L|C}.
7|22 XEE HA ol REJLICE
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3. Gep ME A VIS Fels =g
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A HEFF0{E AXFHAAL.

Google Cloud &2/t 5 CHaf 74

Google Cloud 2 &/7 = CHar 2 74311 Google Cloud & &/ 5 ElAAN £ = =X = l5H2{H ofeH
MRIE 225 AI2.

al: Google IAM @38 2! Mo CHEE AFMIBE L& 2 https://cloud.google.com/iam/docs/understanding-
roles 2! https://cloud.google.com/iam/docs/creating-custom-roles& & Z 5 & A|2.

» Google Cloud 2& 2| IAMOI| A GcP AMH|A | Mof| /7= ZE2EXMEof CHEF UM A HEHE FOo{E L
Ch Z2MEo| #|A W2 ChSat Z &L
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* pubsub.topics.get
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i 4

o CHAMS AASBH 0l TABILICH KA ALRR 7IAI CHA 5 7tol LIS S & E

e Google Cloud &f&/+
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© 2015-2025 AVEVA Group Limited and its subsidiaries. All rights reserved. Page 64


https://cloud.google.com/iam/docs/understanding-roles
https://cloud.google.com/iam/docs/understanding-roles
https://cloud.google.com/iam/docs/creating-custom-roles

'AV EVA\TM Pl Integrator for Business Analytics

AA CHe HE

. a2 o|O| MENSH AR S BEHAIZ HU{E LICH
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EXeag ClOIE{7 QA El= EAF MEQJLICH 7|22t 2
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ors (M) HIAIX| MEO CHE &S fELICE 7|8
e A eLict 7Bt M2 gzip L Snappy L
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3. ™R ERIZ ZFEIEL
4. HAME MEE E2IEFLICE
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Ct.
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2. CFS OH7HEH T E AF2 5104 Hadoop E4F T A|ARI CHA S A& LICH
OH7H g4 43
HDFS URL WebHDFSE 8l HDFSOI| 217 H M| A 8 7Lt

Apache Knox H|O|E 90| EE= HttpFSE & 35H HDFS
ofl HMIASHE URLILICE

of:

HDFS — http://host:50070/webhdfs/v1
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LIC XA MEE Q1B ME A8t < =l
2h2 ME F|AFL(CE

AMEXF OIF HDFsOf| @145t = Ol At El AFE Xt O & &Lt
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O Z FAXFELICH
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a. HDFSOY| C|MEE|E MAdgL|ct
b. O|C|MEE| &R XHE HDFS AL AR B ZEFLCH,
c. O|CIEEZ|7} &8 1S HDFSE #HZAStLICH
d. CIHEZ|ARXHF, HDFS ALERHOA &17| & M 7| HEHE Fo{gLCt,
e. O|CIHER|7} &8t OF 17| & M7 HEtS Ho{FLCt

Microsoft SQL Server CH&F 1 Ad

Microsoft SQL Server CHAN S T 445112 sqL | O|E{H|O|A 0] CHEF 18 EHIAESIE{H of el HAE 2t =28
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Microsoft SQL Server CH & 2 5t ol B LICEH REMEF LI 2 A A CHA F=T7HE F XA,

=
= AL saL A2 R

-

o
£ 1: Pl Integrator Framework MH|AE A&3t= MH|A AP ((E=saL /52 AH83S
0f| Microsoft SQL Server0i| CHEt CHS TEHO| U=X| = IFLIC

MHBq =& - CONNECT SQL, VIEW ANY DATABASE

O|O|E{H|O| A £=ZF - CONNECT, CREATE TABLE

dbo 27|02 Z &8t T E A 7|0} - SELECT, ALTER, INSERT, DELETE

1. 22| Ho|x[olM CHe ®iS SRIFLICH I3 S AA Y SFolAM Ciah S H=ighLICH

142 o|0| MEdE A ChS BHAHIZE ALELICH
2. Ch= o7 =E AFE 3504 Microsoft SQL Server CH&H 2 T+ &HLICTH
OH7Hed = M
SAE O sQL Server7t A& QI A|AEIO| SAE O|F &
QUARIA(SAE 0[§\2IAEA)LICH
saL 215 Ar8Xl O|& sQL Server0i| 1Z45H= O| AR EI AFR XL 0|1B
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Oracle CllO|E{H|O| & HA| CHE ©78

Oracle Ci|O|E{H|O| & HA| CH& & MY 5IE{H HALE 2 ZSHMAIL.

Oracle CI|O|E{H|O| A M| A AE MRIELICH XEMIEH LI 2 Oracle T O|E{H|O| A HM|A 4
QA M M=% |o| LHQC’ =xF X 3|. A|_._

HIAl CH&f 2 PI Integrator for Business AnalyticsOll =7+ LICH HIA| CHA 710|182 FESHMAIL.
Oracle Cl|O|E{H|O|A HIA| CHA 2 & LICH RFMIEF LIE 2 Oracle CHA 7 409| LIS 2 EZFHAIA|
L.

Pl Integrator for Business Analytics | A| CH&F 72440 1235H= Oracle AFE XM A TS 2 2 =4

Oracle HEHE £ 0435I A A|2.
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o A|AHE Sl - CREATE SESSION, CREATE TABLE, DELETE TABLE
o EHO|EAHO|A HEH-EO|EE THE == SESHEET

ES
5. AFSXHOI A AAl CHefoff HMAE HEFS FO{RfLICH CHE ol M| A HEF F 048 A RSHAAIL.
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Oracle C|O|E{H|O|A HMA T 2 A MR
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st <ol ZefLct

Oracle CI|O|E{H|O|A & AHA| CHE 22 7 A /957 Hoi| o] HAHE 2t= &fLIcH

1. Oracle CI|O|E{H|O| A HM|A T Q 4 AZ EQ0{E Pl Integrator for Business Analytics7t A X|El ZHF
E{of| Ax|&FL|Ct.
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fjo
ot
O
o
T
n

2. tnsnames.ora0l A{ \ODAC_install_directory\Network\Admin\Sample I} & &t &L|C}.
3. tnsnames.ora I} 2 T E!St 1T Oracle Cl|O|E{H|O| A0 CHEH & =S F7FHEFLICEH
TE2C20 &Lk

Net_Service_Name =

(DESCRIPTION=

(ADDRESS=(PROTOCOL=protocol_name) (HOST=Oracle_database_host_name) (PORT=port)

(CONNECT_DATA=

(SERVER=service_handler_type)

(SERVICE_NAME=(TNS_listener_service_name)
Net_Service_Name2 SERVICE_NAMEO| CHEH HE ILICH Oracle HIA| CH& & F A& [ Data Source OH7H
B~ E Net_Service_Name2 E & &= Q& LICH tnsnames.ora T+ A 0f| CHE X}A|EF LHE 2 Oracle &

ME ZEHIAIR.

tnsnames.ora I} 21 S \ODAC_install_directory\Network\Admin C|Z|EZ|Z O|S & L|C}.
ODAC 2 Z E 9| 0{9| R|X|E PATH B8 Wi==0i FI+EHLICEH
TNS_ADMIN A|AEL 2t B4+ 5 MM ST tnsnames.ora TFUO| Q= CIRE2|E 7H21ZLIC

Oracle Ci|O|E{H|O| A & A& M HA CHE 2= FIHELICH RHMIEH HE = AA CHe =7t LIS
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N o u &

Oracle CH& 4

Oracle CH&HE 435111 Oracle C|O|E{H|O| A0 CHEF 1A E E|AESHE{™ ot HXIE 2= & LICH
e Oracle CI|O|E{H|O|A HMA 2 QA E MX|EFLICH
Oracle Cl|O|E{H|O| A HMH|A 7 @A MRS HEFHAAIL.
e Oracle CHA S MMSHLICH RFMISH AFRE 2 HA| CHA F710| LIS & ZTSHAAIL.

1. 22| HOo|X|olM CHat &S SRIELICH O ChS AIA CHY SFoM CHe S H=IELICH

© 2015-2025 AVEVA Group Limited and its subsidiaries. All rights reserved. Page 69



'AV EVA\TM Pl Integrator for Business Analytics

AA CHe HE

Ao Cid g olo| MEist B2 o3 BHH 2 HIE LT
k=3
=

2. Ch= OH7HE¥+=E AL 304 Oracle CHAN S T+ A& LICTH
oh7H o
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SAP HANA ODBC CHAMZ BHE Fof| A& LICH RFMIEH AR HHIA| CHA F710| LIE S B ESHAAIL.
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7|12 X0 2 sAP HANA Lo A 2 & AF2K}7} SAP HANA Ci|O|E{0f| CHEF oDBC M AE AFR2E £ &

=
L|Ct E% AF2 Ko Al SAP HANAO| A ODBC HMIA E H|E A5l 510 HMAE AEHE 4 &Lt 5t
X |8t Pl Integrator for Business Analytics | A| CH&F 4401 21243+ = SAP HANA AFZ XHoi|H| CH=2oF 22
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* SYS.SCHEMAS, SYS.TABLES 2! SYS.TABLE_COLUMNSO]| CHEH ME4 #EHo| 2 BhLCt,
« Ef|O|=E BHE A 7|0to] CHaH CHS HEto| 2R EfLCh.

o ALTER

o CREATE ANY

o DELETE

o DROP

o EXECUTE

o INSERT

o SELECT
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4. HAE E4|7t =/™ HIA| = O|X|2 o|S & Lct.
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Select Data > Modify View > Publish

ource Assets earc ape atches
S A = S h Sh v Match
T_Asset Shape

Server CAST-INT-CL v

Database Datacenter Dema [

® Assets E}-\_lto drop and place
4 () Data Centers @ Calot
4 Q) Americas
4 @ atlanta
| » B colof —_—
» [ Colo2

» [ Colo3

» D) Chicago

Attributes | % |

0 select All

& ColoNumber
& Zonel.Capacity

& Zonel.CapacityPercent

& Zonel.PUE

e
e
o
& ZonelDCIE (]
o
& Zonel PWR (]

o

& ZonelRollingCost
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@ Source Assets T Search Shape ' Matches
Server CAST-INT-CL v ToAsset Shape Found 16 Matches
Database Datacenter Demo oo * QColotempiate P x> ©cool
& Zonel.Capacity a4 » @ Colof
@ Assets
& Zonel.CapacityPercent " » G’] Colo1
4 @ Data Centers @ Zonel PUR * % @ Colof
° [l & Zonel RollingCost * % » @ cColot
4 [ Atlanta » @ Colo2
> @ Colot » @ Colo2
> @ colo2 » @ Colo2
» @ Colo3 » @ Colo2
4 [ Chicago » © Colo2
> @ colot » @ Coloz
> @ Colo2 » @ Colo3
> @ colo3 » @ coloz
» ) Houston » @ Colo3
> e New York > @ Colo3
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¥ Attribute Name
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Attribute Category
Cost r

(+) Add Filter

¥ Opticnal Attribute e
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o #Et EAIZIS 2 O] Hl0|EIE MQlsto] WEIE MEE + UALICH ol 32 AT 27]o| Fntot
255t YUx|stetE HO|X|of O|O|E{ 7} E AIE| K| et& Lt
13. CtS2 22!5t04 HIO|E{E HIAIZLICH
14. CHE 7 SEo| M CHA S MEHFHLICE
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Select Data > Modify View > Publish Next
"4 Source Events v " Search Shape @) + Matches @)
Server @ DFPIAF . HH Event Shape @ Found 62 Matches
Database OSPhammaClP - 4 'Y CIP_SKID_EPRINSE:1-1 # x » "H CIP_SKID_EPRINSE:1-1
ama - A @EPRINSE G & X » "8 CIP_SKID_EPRINSE:1-1
l T ‘ Enter Event name or string match pattem @j 4 CIP Flow Rate (to User) &S x » "H CIP_SKID_EPRINSE:1-1
Event Frames Assets @) & CIP Flow Rate (to User) High &S % » "H CIP_SKID_EPRINSE:1-1
) EPRINSE | - & CIP Flow Rate (to User) Low # % » "d CIP_SKID_EPRINSE:1-1
4 " CONNECTING &S % » “H CIP_SKID_EPRINSE:1-1
) EPSHUTDOWN
© erwash 4 QICIP_124_SKID @ j % » " CIP_SKID_EPRINSE:1-1
b 9.
, @ LT & ACID SUPPLY FLOW Fa » "8 CIP_SKID_EPRINSE:1-1
» © CIP_432_SKID 4 ACID SUPPLY TANK LEVEL CON.. & X » "H CIP_SKID_EPRINSE:1-1
) & CIP Acid Tank Level &S % » "H CIP_SKID_EPRINSE:1-1
» (D Environmental
€3 1 terrmlate - 4 CIP Caustic Tank Level &S % » "H CIP_SKID_EPRINSE:1-1
—mH » " CIP_SKID_EPRINSE:1-1
Attributes | Filter @ % | » " CIP_SKID_EPRINSE:1-1
J » " CIP_SKID_EPRINSE:1-1
O Select All
» "8 CIP_SKID_EPRINSE:1-1
& CIP Flow Rate (to User) i} » "8 CIP_SKID_EPRINSE:1-1
& CIP Flow Rate (to User) High [} 5 | G S L ETREE T
& CIF Flow Rate (to User) Low i) » " CIP_SKID_EPRINSE:1-1
& CIF Flow Rate (to User) Parameter i) » " CIP_SKID_EPRINSE:1-1
& CIP Supply Pressure i} » " CIP_SKID_EPRINSE:1-1 -
CHS Z= Ol HOIX|o|CtE B E WOoHE E7| =62 Me i O] H|O|X| AHS S MHEFLICH
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M4 Search Shape
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4 "4 CIP_SKID_EPRINSE:1-1
£ EPRINSE
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v

Server DFPIAF

Database 0SIPharmaCIP

¥
-

Y | Enter Event name or string match pattemn

Event Frames Assets

» "8 CIP_SKID_EFPRINSE:1-1
4 "4 CIP_SKID_EPRINSE:1-1

» " CONNECTING

» " DOWNLOADING

» "H STARTING

» " RUNNING

» "H UPLOADING

» "8 COMPLETE

£ EPRINSE

P SJCIP_124_SKID

» "4 CIP_SKID_EPRINSE:1-1

» PH CIP_SKID_EPRINSE:1-1

. S Bols ME 2 A0 CHE 54
. EEMoR M BR0IE A5 S8 YHIE AS
scE¥ Bl
x| BHAE
A%
7+ Sefoll ol0| EAIE JHHIS] BHZ 49l & 59| T
& etk

A RS =5 X HIRI
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M Search Shape
" Event Shape
4 by &S x
£0) EPRINSE G & x
# x

i COMNECTING

@ﬂ_l,'_o drop and place
&0 CIP_124_SKID

£ 10: Pl Integrator for Business AnalyticsE & S
CtH.
. OHIE ZEQ 24 & 442 OJHE Hej £2/9 ot RofLt BoiTt O MHAE 491 24, 5
ARAEESI AR Boltt s22te =7 HdHO| ZA[ELICH
B piAF AT UXISHK] o= fIxlof obFH al 9l0| M E EEE =+ U&LICH
T8 Eg|oM 7HA ZBoict =7
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M4 Search Shape
M4 Event Shape
4 P CIP_SKID_EPRINSE:1-1 & %
£7) EPRINSE % &S x
4 " CONNECTING F x
%S x

Eﬁ@ﬂ 124 SKID
Drop as child
# ACID SUPPLY FLOW

ABIAOM O|HE HE FHollM HEHE W4dstod o2l 3HH X ol EAIE CHz &40t &7
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M4 Search Shape
¥ Event Shape
4 "4 CIP_SKID_EPRINSE:1-1
4 [ EPRINSE %
& CIF Flow Rate (to User)
& CIP Flow Rate (to User) High
& CIP Flow Rate (to User) Low
4 P CONNECTING
4 FACIP_124_SKID %
& ACID SUPPLY FLOW
& ACID SUPPLY TANK LEVEL CONTROL

& CIP Acid Tank Level

B 0% % % % % % %R N R
X X X X X X X X xXx x X

& CIP Caustic Tank Level

O|HIE HEHOIM 71E =2 O|HE Z|olM & X8 2
ME PIAFHIS £ R0|A CIP_124 SKID 24 /0l Y= A2 2
QAN ESHEEE QA EHRSCHH AT AT E 2
MEZR).

HAEE R 33
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*H Search Shape

*H Event Shape

W CIP_SKID_EPRINSE:1-1

OO

4 FEPRINSE
& CIP Flow Rate (to User)
& CIP Flow Rate (to User) High
& CIP Flow Rate (to User) Low
" CONNECTING

4 FACIP_124_SKID

CFee

B 0% % % % % % % R R R
X X %X X X X X X X X X

& ACID SUPPLY FLOW
& ACID SUPPLY TANK LEVEL CONTROL
& CIP Acid Tank Level

& CIP Caustic Tank Level

QIZIE XHLt OfOZ S B2I5HDH F RN A QI AH HEY B 0| EAITLICH T 4, ST 44 U s
249 448 X EE| #22 O|SELIC of ollol M Ll 7Ho] 2 ATk &7 cip_124_SKID 247} X
e} Aol SAFEILICH of2hol 3 Zx{of M OI8 & & A&LICH

el Aol F7HE Kot el

0

0
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M Search Shape
HH Event Shape
4 " CIP_SKID_EPRINSE:1-1
4 FIEPRINSE
& CIP Flow Rate (to User)
& CIF Flow Rate (to User) High
& CIP Flow Rate (to User) Low
4 P CONNECTING

£D CIP_124_SKID

T= Asset Shape

4 ACIP_124_SKID

& ACID SUPPLY FLOW

& ACID SUPPLY TANK LEVEL CONTROL

& CIP Acid Tank Level

4 CIP Caustic Tank Level

Ko SHE) ZolM pIAF AT F X0 EAIZIE @IXIQF 4 2H810]

O A Ol & A
=

S

Pl Integrator for Business Analytics
Pl Integrator for Business Analytics A& & &

B O% % % R R K
X X X X X XN X

B % % % N
X X X X 2

0{l A= L1 HuMAB, NorthStreetPllant 2! Philadelphia 2 A&7} XFAF EEJoi| F=7HELICY.

RHAF SEjol| FIHEI 4
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Select Data > Modify View > Publish

"4 Source Events

w " Search Shape

Server DFPIAF . "H Event Shape
Database 05 IPharmaClp . 4 ¥4 CIP_SKID_EPRINSE:1-1 &S x
4 EPRINSE G & N
I h ¢ | Enter Event name or string mateh pattern & CIF Flow Rate (to User) &S
Event Frames Assets & CIP Flow Rate (to User) High a4
4 @ Data Centers & CIP Flow Rate (to User) Low Fx
» ) Americas 4 " CONNECTING S %
4 @ Pharmaco KD CIP_124_SKID G & X
4 @Nor‘thAmerica
4 () Philadelphia
4 [ NorthstreetPllant
4 @ L1 HuMAB
&) CIP_000_SKID
» @ CIP_123_SKID
» ©cCIP_124_SKID ‘ T Asset Shape
» ) CIP_422_SKID 4 [ Philadelphia & x
» € CIP_432_SKID 4 @) NorthstreetPllant # x
» (D Environmental 4 @ L1 HuMAB S x
@ no template 4 £DCIP_124_SKID %G S X
» (D syringe & ACID SUPPLY FLOW & n
» ) TSTA # ACID SUPPLY TANK LEVEL CONTROL & x
(GRek! & CIP acid Tank Level &S x
» © T & CIP Caustic Tank Level #
» @112
Rh+ SEHOI M AZIE RHH BT E B2UsHe Z2 K HEH B 0| ABHAIH HTE R U &4 H=0| of
HIE el &ofl ghetEuict
D QAE KA HEf HOE 25t RLUSH O|FEPIAF AIS £ M 2o M= 24 D &HHES
ZEotT| @Igt LI "efo| SRl e 27|E AAlSte ol AL E|l= AlZto| E7HE = /J&LCt
O = |
AERUEHT|IOHET
ZF1: O] 7|52 Pl Integrator for Business Analytics Advanced O|C|M0{ M AL & = Q& LICH
CIE22 AEEY E7|E BtE= 7|2 EhA[of CHEt JH LC S HAIZE o|sE @3 & F =g ct
1. AEZ|Y E7|9o Hel Hol,
2. TH3 5 3t 7hRI WO R B0l AL A7|0HE MEiBHLICY,
o IAUOA 7RI AZ|OFALS
o AF|OtBIRIAER|VIM 7HKA2 AF|OFALE
o MHEIATIONALE
A7|otol CHEE KM LIS S A7(0} HE B HESHAUAIR
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3. HAIXIE B M 4.
HIAIX| EE[7Ho] CHEE REMIEF L8 2 HIAIX| EEI7H HEE B XS AIL.
4, (&M) 2HE (backfill) H|O|E.
5. (M) dole EEHZ.

A7|o0F AIR|AE 2|0 AF|OF Xt

oY = WMHE AFOMM 7HK2 AF|Ots A 7|0 BRI AEE|0| HEE 5= U&LIct ol 2hA e
O| 2= A7|0HH= Avro A7 |0FE KZHEIL|CH A 7|07} KZHE|H HIA|X| C|AFO|L] & 2| AF|Ot= A 7|0t
HIRIAEZ|of 2t M E|l= Ao SSE UL ek AF7|0HE BIXIAEZ|H| K& 57| o LIS
ZAsH{oF &Llct.

. A7(of g R|IAER[Q HAIX| CIAtO|LH &M BIXIAEE| AHE FEHS 22/61H HANIE A 7|0} o
22 MHE = d&Lich

ol E2ladM A7|0tE 70 AIRIAEE|MEF MY E + QJELICH U= MEE + gl&LICh

1. BE7]=d ho|x|oM BIXIAER|of A7|oF MY S F2IFLIC
HI: 0| EHFE EAlstt{H A7(0F FME M=islof g LICH

HIXIAEE|o AF7|OE MESHZ| ™o AF7|0F EEE THE
SHEfet STIBHEIX| ot E, & Ae g4 A
ME wHZ4s5te{H EM4 8 Boict =&LICH
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Message Designer

Schema Options Message Trigger Backfill Data Message Filters
Free-form mode Trigger a new measage when 1 key Do not backhll data 0 filters
values change

‘You are not syncing (free-form) your schema to the asset shape.

Import Schema Select Schema Structure

| Select Import Source - | | Fres-form - |

{
“Timestamp™: “|(¥) TimeStamp v, s
“Zonel.Capacity”: "¢ Zonei.Capacity (Value) v, & x
“Zonel.CapacityPercent”: "|J Zonei CapacityPercent (Valug) v |", &S x
“Zonel.PWR": "|4 Zonel.PWR (Value) v, & X
“Zonel.RollingCost™: "|4 Zonel.RollingCost (Value) v, s
“ColoTemplate™: "|@ Colo1 (Name) v & X

¥

2. BIRIAER|o| A7|OF XE & o] AF|OF MIR|AEE| URL ZEO| AF|OF HRIAEE|Q Q%|EK|XEL

ct.
gl ool 2248 AESH AL 7t58 AF(0t SR |AEE| S5 0| LIEHELCH
3. A7|0t NS E=ol A7|0F O|FE YUHst MY S S=ELIcH
270t 54 & YR §HE2 4TS HEY + J&LICH a2{L O ol & 7|0F §8& AE-Es ALt
MY = &Lt
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You are using the schema "ZoneSchema” from the schema registry at http:/10.4.200.128:8081.

Import Schema Select Schema Structure

{
"Timestamp”: "|(®) TimeStamp v, P
“Zonel.Capacity™: "|4 Zonel.Capacity (Value) v, SR
"Zonel.CapacityPercent™: "|JZnne‘1.CapacityF'er-:ent (Valug) v |", &S x
“Zonel.PWR": "|4 Zonel.PWR (Value) v |, S x
“Zonel.RollingCost": "|4p Zonel RollingCost (Value) v, PR
“ColoTemplate”: "|@ Colo1 (Name) v S x

¥

o IXIAEE A8 SEE Z2Istod 27(0F IX[AEE|of CHEF o] A7|0F HAE MHEY == A&

LICH Ol H| 5t A 7|0HE X 3H7| Tof| HEE & U= HEIZE oty = J&LICH

HA|X| EB|7H HE

HIAIK| E2I7H= HAIXIZF HA| CHAF Ol S El= HIE of TS AXBHLICH E27 R80ls AlZHZH
of 2 Ea|Het 7| 2t Mol 12 E2747F s ||:+ E 7| 22 Pl point £40[0fok BFLICH Ol2{3t
S M2 ol AT Bl EAlE0f QgLICH

9 Trigger a message in regular time inter'.'als:| 1 b || minutess” |

#) Trigger a new message when the key value(s) selected below have changed
@ #) Trigger a message when any of the selected key values have changed

Trigger a message when all of the selected key values have changed

Trigger on Archive Data (@ Snapshot Data

o 1. AlZtol [HE HIAIX| EEA
o 2.CIOJE] Zto| #HE0] [HE MIAIX| EE|H

ofl Mol M ol et SMS AIR 6t bt

T
-l
fjo
X
m|
ATH
g'l_-
r
ul
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LB AlZH ZHHo 2 HIAIXK| EE|A

ge = A&Lch HAIX|= HIo|e #HE o{F ot Fat5t7| X|

3001l M Z|CH 1270 Abolo| AjZt 7tz A
8t 80| HAIX| EE|IHE A3 BY|Z o2 El AERY 272}

ME AlZh ztAoic MSELLCH ol
0 gLlc

1 HIAIX| 27| L ol 2 CHA Ol A CIO|E{E 4= A1Eh Il X|Qd0| gh A& 4~ Q& LICH 24Ol PI System
off ==& mfoF CHAM AA R0 =2HE o] 7HZAQI of| x| ZFH CHZ| AlZH2 MIA|X| E2|7 Ato|2o] ZHAEL} 2

= AELICH

HAIXIE EE|HetE 7| Al

oz EE[HE AEE|Y E7|2ta ghLict ot 23 BlIXFoME prEN 0] SHE 8t 7| Zonel.PWR &

Zonel.RollingCostE MEARNELIC

HAIXIE EEHY 7| HE At E AHE & JU&LICH Oz et R HAIXI EEHE AHEEH EVIE 7|
. Gl
F
Trigger a message in regular time intervals:
® Trigger a new message when the key value(s) selected below have changed

# Trigger a message when any of the selected key values have changed

Trigger a message when all of the selected key values have changed

Trigger on Archive Data ® Snapshot Data

Q, Message Content

I
L

"Timestamp”: "|(¥ TimeStamp v\, S X
"Zonel.Capacity™: |4 Zonel.Capacity (Value) |, &S X
"Zonel.CapacityPercent”: "|4 Zonel.CapacityPercent (Value) » ", S X
s/ "Zonel.PWR": | Zonel PWR (Value) |, S X
¥ "Zonel.RollingCost": |4 Zonel RollingCost (Valug) L P
"ColoTemplate™: "|Colol (Name) v | a4

7|1€ AMEatH HAIXI7L EBIHEIE ZHE FIM= AFSXH X|HE & &LICH
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Trigger a message in regular time in'ten-'als:l 1 w || minutes vl

® Trigger a new message when the key value(s) selected below have changed A _T_

#® Trigger a message when any of the selected key values have changed

Trigger a message when all of the selected key values have changed A \.,_/

Trigger on Archive Data (® Snapshot Data =] v
Q‘. Message Content
{
"Timestamp": “|@Timestamp r|", S x
“"Zonel.Capacity™: |4 Zonei.Capacity (Value) v |, & R
"Zonel.CapacityPercent”: "|OZune1.Capacit!.fF'ercent (Value) '|", F X
= “Zonel.PWR": |4 Zonei PWR (Value) e &S R
L “Zonel.RollingCost™: " Zonel RollingCost (Value) v |, B
"ColoTemplate™: |[§§j Colo1 (Name) LA S X
¥

Olefet M= &= 2 of2fofl B T(o] U&LICH

7| gtol HEEIH HAIX| EE[A

w2

SR 2442 MEIBH 7|0l CHEH CIOIE{7} ket HZEIM HIAIXIE E2I745Hs ZYLich

Trigger a message in regular time inter'.'als:l 1 il ” minutes™* |

#) Trigger a new message when the key value(s) selected below have changed

) Trigger a message when any of the selected key values have changed

Trigger a message when all of the selected key values have changed
Trigger on Archive Data (® Snapshot Data

CHS2 ol SMo JeH= E3ULICH o] 2Bl 7| A%t 71B7H ZEAIE0{ (e Moz HAIE 7| & &
L7t e ZE miokct HIAIKI7F EBIHELICH HAIXI= ZQl A 2011, 12, 13, t4 K 150 A MSE L
ct.
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t1 t2 t3 t4 t5

Key A q\, —T

Key B Q\

(-] v v vv Vv

DE 71 2ol HEE Fol2 HAIX| E&|AH

FHm M2 ZE 7| g0 HEE F02 HAIXIE Euis R

Trigger a message in regular time intervals: | 1 W ” minuiess |

® Trigger 2 new message when the key value(s) selected below have changed

Trigger a message when any of the selected key values have changed

# Trigger a message when all of the selected key values have changed

Trigger on Archive Data (® Snapshot Data

CtS2 ofoil CHEr e Z LICH t2, t4 K 170 M Ml ZHe| HIAIXI7F MSELICH ZH M2 HEE 210
7S EIRE S LIEFHLICH B Mo 2 T AIE A0t ZHol 52| 2t 2 MEE[X| ek& Lt
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AV=VA"

Key A Q‘. ‘ ‘
b
Key B Q.‘
t1 t2 t3 t4 t5 té t7
(-] ' v w
HAIXIE EE|7Hét= lolH &
AHAE 2L E ofH 22 2 HIAIXIE

3 Qlof T, of7to|E Zfo|Lt

il ” MINUIES |

Trigger a message in regular time intervals: | 1

® Trigger a new message when the key value(s) selected below have changed
Trigger a message when any of the selected key values have changed

#) Trigger a message when all of the selected key values have changed

Trigger on Archive Data (® Snapshot Data

HAIXIE 24 mf 74
HAIKI E214 HE B2 daUch HAIX| E2148 4Ess ol B3 ¥z |42 MIBEUC
R

1. B7| ™ Ho|x|o|H HIAIX| EB|HE Z 2L},

Page 124
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2.
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=R My
A H7| Azt Ho 2 HIAIX| EB| | HIAIRIZL 7] 2F B8 o{ R oF 2t
7 Hglo| XIHE ZtHc 2 MEE
L|Ct.
B of2Holl M MEHEE 7| ZEo| HAK! | HIAIX|7L 7| gt BdEol et T
™ M HAIX| EEIH SELic

= =
« BE ME{EI B 4EHAIFE AL T LICH
(AOH|2F M Z) HAIX| Abol2l AlZh ZHAE X Este{H 552 =L
3001 M 1270 Atole| ZH S MEE + &L

HIAIX| AlzZt 2+

# Trigger a message in regular time intervals: | 1 W | minutesw

Trigger a new message when the key value(d 1 seconds
2 minutes
3 hours
4 days
3 months
3]
v,
8
-

g L
MEit 7| gtol stLtete HE XM HAIX| E2l | 7| 2L0] stLtete HEEH HAIX|7F E2[AHE
ya LICE.

MEE 7] gto| 25 WHEM HAIXI E87 | 2E 7| 2ho| HZElofof HIAIXI7H EEI4EL
ct.
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c. MEHEHZ|of AL 2L HE A = of7H0|E 2f HE MEE HIAIX|o| EEHY WX R E
EH St
=

O3t M=40] T El= GlOJE{o] DIxlE Boll Cha A TIAIX| 217 HE 0l I8 2 A ZHAIA
(@}

—r.

O{fH Cl|0|E 7} CHg 2 =2 MESE LI

HAIXIE 2 Al7|8 TAIE & 2 Hl0lE KBS AT LICH 2t 24 S50IM 2 S48 Mg 4

U&LCt.
&3 7| 7|8 AlLt2|22] B HIAIX|(0F7I0|E EE= AH4FE EE[7SI= CIO|EH f82 AXE Olde
2 MEE|= olo|Eet FEELICEH o & E04, 9I°I¢'— 4F Cl|O|E{& #HEst™H HA|IX|7F EE|HEIZE K|
BE 4+ AL 221 79| of 7ol A 2t of ol Aoz HSEITE XHE £ 2aL)
Cl. of2} 23 24kl A Zonel.Capacity S 4301 CHEt Zf O] MEHZ|A&LICTH
ng Message Content
1
"Timestamp”: "|(® TimeStamp ",
v "Zonel.Capacity”: "|0 Zone1.Capacity (Value) |,
. _ ] Template - "
Zonel.CapacityPerc Category lue) v [",
" L1] " Path
" Zonel.PWR™: "|4 Zon Description
. . . Guid .
o Zonel.RollingCost Ty L
LastR ded Val
"ColoTemplate™: "\ Tgfal SOCET =
} Average
Minimum
Maximum
Range
Standard Deviation
Standard Deviation (Fopulation)
Count
FPercent Good
Snapshot
Time Opiions
TimeStamp
Year hl
CtE AlLt2|2= HIAIXK|Z7E EE|HElE ZHE dHELICH

o AlLtZ|2 1: 7+ d|O|E
o AlLI2[2 2: 0t7}0|E Cl|O|E{Q] 7|7} ¢ B =T HIAIX|7F EB|HE
o AlLt2IR 3: ARAFOIO|E 2| 7|7F HA R HIA|IX|7F EE|IHE
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2 4EOIM S4S CHE 2t M Ao TME £ JBLICH AILEIQE 2, HXI ez 7|5 E 3t &
AL MEHABO 2 SXS TAE Mol 2THE ATELIC

AlLtEl2 1: Z+4 dlolH

of et MSELICH OS2 oMol M 113k ta7} AlZH ZHZ30| A|ZHat 22 E Al

A diolE= X|IEE 7+

LICh HIAIX| EFUARAT = t40) AlZHLICH M&E|= Ol OlEHE S490il ChaH M=43t Ztof k2t chE Lich

o EMO|AHAFZICR THEI AR 30| AAF ZLO| t42] EFYARY = o} B S EILICEH (1)

o OiX|2o 2 7|&E Ztof EH?_FEMOI-TWEIN U™ HA|IX| EFAARH T It MES E|7]| Tof OFX[2e
2 7|5 2t0o| & ELICE o] oMol M= t22] of7t0[E 240 t42| H|A|X| EF AR Z o B TH TS K
oA | |. ( )

AAH

2ol CHE £450| P[0 U™ AlZh ZtZH 9| ot 7to|E I AHAF ZEol 4] 27t 212 Hldtst= O

A EILICH3).

time interval

tl t2 t3 t4

2
O O

message time stampJ

Key

Ot7}o|E &t

>
L
s
.

HL
)
=

© 2015-2025 AVEVA Group Limited and its subsidiaries. All rights reserved. Page 127



'AV EVA\TM Pl Integrator for Business Analytics

Pl Integrator for Business Analytics A& & &
AlLIE|2 2: ot7t0|E O|o|E 2] 7|7} HAEIH HAIX|7I EE|HE

ol otzto|le e AHAF Zk2 EB|{EFLICH20d). t22] of7+0| = ZLo| HIA|R]

t30]] AHAF ZLO| & t2
= 2QlLich ChS 22 MEfst Zhof et cHa 2 2 ME L= H|0|E{E £ 04

04
£ E2|H5IH, EFIAEY
& LCt.

(@)ut]
_I_l_
i

o OIXIZSZ 7|SE ZL OIOIEHZ A7} A HE B2 t22] of7+0|E Zho| M&E LICHa)
o ZIOIOIE{Z A7} T MHEI AR 20| E7Zt Zo| S EILICH)).

OrEF7HR| 2 §4 Boll Ciall TS &= ololEE 74 ol ket Fat&Lct

o OIX|HSZ 7|2 E Zt2 HIAIX| EFRUAB Z(t2) O|F EE &= 1 A7 2| PI Data ArchiveOll & & & FRH 43
ULICH O] oM ORI 2 7|SE 2t 2 7t FHE A t2 0| & ¥imY L2l ot7t0|= 2L 0|
MEELICH2).

o L OOIEHZ B7I +ME B2 t19| 0I7I0|E gt} 39| ARHAF 2L 2 AFE 3104 1204 TI[O|E{7F B ZHEIL

CH3).
message time stamp_¢
t1 t2 t3
1
v Key A

Key B
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AlLtE| 3: 2458 T|0|E 2] 7|7} HEBEH HIAIX[7H EEIHE

2to| HAL|H HIAIX|7F EE|7{ELICE o] Ao M HIAIXI= 7| Aol M E2|7HELICH 7] Add|

7|0 ALHAF

CHE A AF CIO|E{ 7} t30] HIAIX|E EB|7HEH HIAIXK|Q| EFUARMET = t3]L|CH t30] A4 2LO] 7| A

2 grErElLICHa).

7| B EB|HStE 7|2 MEHE|X| of&LICH 5 MM 7|01 7| B2l g2 Y F4Jof et Z-EELich

o DIX|HSZ J7|EEIZISZ 7|7t HE F2 119 ob7to|= Zhat 74 32| HIAIK| EF AR Z 7} X
SELCH?2).

o AHLZIOR F|p7t THE B 129 AHAF 2L0] t32] HAIX| EFRUARHZ o &4 &S ELICH (3)

o USE 7|7t THE B39 E7F 2L0| t32| EFUARHZL o E 71 S E LICH (4)

message time stamp_‘L

t1 12 t3

v Key A

Key B

MEEH 7| Zhol T HEEH HAIX| EBIH SME MEE 32 2 E 7|71 HE Elo{ok HIAIX|7F EE[AH
X|9f 7o EFUA R Z 7} HA|

= r
SILICH ME4Et D E o] Hah A4 3O HHEHEIT, A Zh HHEHE o
NEHEE-LI=Y

[ el == |

o0
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A2E2|Y 27| cl|olg 0l2] 27|

CilolEf OI2] 2 7|ol= &4 ot7tol=2 Zhol EAIELICH WEtM HAIX| EEI7H dE ol Atz Qls AL
ClO|E{7l CHed o2 MEE B2 o 24 CIOIE = O|2| 27(0l ZAIE|X| 2E&LICH OF7HO|E Zho| E A

L

A2 E dlolH

7|12 EEIHE AEC|IY E7|= 0tX|2t O|HIE S| EFHARHZ O|™of| Bt HARHZ T} QI O|HIEOf CHEF O
AX|E EE|HstR] k&L

SH Z| (hackfill) G| O|E

CIOIE{E HIAISHH ZEHC| $4AH ZtO| CHA S 2 MESEILICH OB E WEISto{ O|™M 2 7HKE = UE
Lict.

1. BHEI HO|E{E o U E AEE|D E7|0|M X|HEIHOIO|EIE RIS 2 UO|0|EE £ Q&L 7|
o2 ER|HEI AEE|Y B0 ME R E| K| SE&LICH

1. 27| ™ o o|X|o| A B El(backfill) CIIO|E{E Z2I§tL|C}.

2. YEl(backfill) CllO|E{ A|Zt Y& E=2]EHLICH

3. HIAE MXlolM &2 of0|2 S E=I5t0{ E =242 Lt

4, HHS AJES D AR EWE E2IELICH
D —

AED|Y 27|90 el 9|

Aot 2 22|18 C|OIEE BA5ted™ KA 27| Ao LIS & ZsHAAIL. O|HIE T2 o|o|H

E BEMEe{H o[HIE 27| MMHo| LIEE & XS AMAIR

1. M+ ofo|Z g 22l5tn AER|Y B MHEVIE E2IFLICE

2. Hol CHst o|§E =dghLct
Z0: 0| E7|7F AAIE CHA o] R 75|18 oHAFSFLICH RIMIEH LIER2 27| 0|& 2 A = %20l E
ojLiee &HEsAAIR

3. Pl Integrator for Business AnalyticsOfl M| A S o= Q1= 0424 PI AF IDO| AFE AL H'HO| EE El0 U= F
P HMA HMELS 2=6tT E7| HEH S 2048 DE MEHFLICEH

Bt 7H2] P1 AF IDOY| Bt PI Integrator for Business AnalyticsOfl UM AE 4= Ql= HEHO| F04E ZF< O] D7}
sz Fof gEELCt
2718 X3 MHE HOI PI AF IDOJ|BF H A A

- 2 &LICt LF&of =7t pi Al DO
OHM|A et Hodst 4= Ql&LICH AIM|Et Liee 7| 2
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Pl Integrator for Business Analytics
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4. H7|8yg 23
5. HE Rt FolM M He) Mg F2IEL
Ha:CHE 27|0M BE| 71X 27|§ 235101 7| SENE AFRE 4 QlaLch
6. At & HIOIHHIOIA L= E M83t0{ Rt PIAF Server X H|O|E{H| 0| A E R &L
g3 7hEo| AXK Yo ALE X7 270l AFSE CIOlE] HAMA DE £ £ 2l BE 7 EAIEUCH
7. PIAF EE|E S C}25t0] 2 ME Rk HaLint
8. Arih2 R HEf Ho2 FZLch
A R HEf Ho g2 |

Select Data > Modify View > Publish

@ Source Assets T Search Shape

T_Asset Shape

Server CASTINT-CL v

Database Datacenter Demo

Q) Assets
4 () Data Centers @ Calot

- 8 Americas

- 8 Atlanta
| » 63 Colot —_— |

» [ Colo2

» D Colo3
» ) Chicago

Attributes | % |

0 Select All

& ColoNumber
& Zonel.Capacity

& Zonel.CapacityPercent

& ZonelPUE

& ZonelPWR

o
o
o
& ZonelDCIE ;]
o
o
e

& ZonelRollingCost

Thuto rop and place

+ Matches

= —
1 S8 FHeAL, HFEE 2B, EAISE 552 BEfgatol Hsts 542 2
g 4+ glaut.
RS E& L HIRIE ALRShod S4d 57}
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Select Data > Modify View > Publish

Ea Source Assets T Search Shape + Matches
Server CASTANT-CL - T_Asset Shape Found 5 Matches
Database Datacenter Demo ooy & Colot s X & colot
@ Colot
Assets
CD ) @ Colot
A fa Data Centers Q‘ t | @ colof
L utoc drop and place
4 America -
Ea § & Zonel.Capacity @ Colol
4 (@ Atlanta
| » @ Colot
» @ Colo2
» @ Colo3
» @ Chicago
P+ S
Attributes ‘
O Select All
4 ColoNumber

‘ & Zonel.Capacity

& ZonelCapacityPercent
& ZonelDCIE
& ZonelPUE

& ZonelPWR

eocoo

# ZonelRollingCost

4

I N E A HE EE| o/ F 2 BHAS E8 L HiX| HIAEQ 37 =7 HHOo| EAIELICE
27t =eld fx[el EElo RS2 2 FIHEILICEH 0| 24 = PIAF EE|of U= Rt HE EZ|0lMH 2
2 #HE |XIFUC /IxI7t eis 42 E&0| AR ELICH

AHot e ECol FHAE Hi XS =2 U&E IEP RS AR, 5P EE S5 LAR FIIHSIE S CHLY
st =7 AHO| EAIELICH I AF AIS T LX|GHK] &t = $le01| O W3l gi0| 7iXE EEE =
A&Lct.

Kot el E2lo] 2 4 v
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Select Data > Modify View

[ Source Assets

> Publish

Server CASTINT-CL

Database

Datacenter Demo

0

[ Assets
- @ Data Centers

- 8 Americas

| 4 e Atlanta

» @ Colot
» @ Colo2
» [ Colo3
» D Chicago
» 0 Houston
» (D New York

3 @ San Leandro

10. ZFII ROl EME X
ol
=

11. Z2PAFRESIE SRSIE

o
Pl
=
k=]

I

ot
[
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T Search Shape

T Asset Shape

4 Th op as parent

() Atlanta

Pl Integrator for Business Analytics
Pl Integrator for Business Analytics A& & &

+ Matches
Found 5 Matches

» @ Colot
» @ Colol
» @ Colotl
» (D Colot
» (D Colot

N,

NN, NN,
X X X %X X

Pl
£
2
m
—__
i
o
o
n
111

L
u
-
2
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Pl Integrator for Business Analytics
Pl Integrator for Business Analytics A& & &

) Source Assets

T Search Shape

' Matches

. CASTINTCL T Asset Shape Found 16 Matches
Database Datacenter Demo 4 @ ColoTemplate "% > © oot
& Zonel.Capacity % @ cobot
@ Assets & Zonel.CapacityPercent a » @ Colot
4 @ Data Centers @ Zonel PUR * % @ Colof
4 @ Americas & ZonelRollingCost " % > @ Colot
4 [ Atlanta » @ Colo2
» ) Colot » @ Colo2
» & Colo2 » @ Colo2
» [ Colo3 » @ Colo2
4 [ Chicago » & Colo2
» ) Colol » @ Colo3
» ) Colo2 » @ Colo3
» @ Colo3 » @ Coloz
» B Houston » @ Colo3
» B New York » @ Colo2
» @ san Leandro » @ Colod

12. CIE 54 &E0| U= HIRE RHtolM LR =S HoedH:

am
0
o
ne
4
N
o
[
iz
Ijo
i
am
0%

# Attribute Name

Zonel.RollingCost

Attribute Category

Cost v

(+) Add Filter

¥ Opticnal Attribute e

13. ChS2 SEIFLIcH

© 2015-2025 AVEVA Group Limited and its subsidiaries. All rights reserved. Page 134



AV=VA"

H7| £ HOo|X|7F EAIELICH BE7|E2 £857| ¢

Holxlol e &XstAAIL.

14. C}E Hit & otLHE 22 5t04 CO|E{ol| et & 7[0HE

o AH

dHE A7|OFAE

olM 7k A 7|0} At
OF X AE2|0|M 7L 2 AZ|OF AL

° 0z

o I

=lOI=I
1
0%
ol

Pl Integrator for Business Analytics
Pl Integrator for Business Analytics A& & &

HoF 5t= Aol et FHeE 27| +H

=HErLlct

. A7|0F SMof CHEt REMIE LI 2 A 7|0 HEE

EH oA s 542 188 s Zo| MEEH He} R
B THE10| U1 £3 Hlo| 20l 2t 54 K| CHEt Ho| &

A& LICH o & ET, 048] §49| 0§ S4oi
i 2l Elolg g disteis @%gn,n:} c}

= ol XMofl= 37H2] Zonel & A2l Zonel.Capacity, Zonel.PWR (Power), Zonel.RollingCost7} Q& LICH O|2{&t

£ A (Capacity, PWR, RollingCost) Zone2, Zone3 & ZonedH{ =
Zone2.Capacity, Zone2.PWR 2! Zone2.RollingCost I LIC}. O|2{&t

ATJBIL2 OlpIAF RO B E 27| LCH
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[ Source Assets

Server

Database

@ Assets

Pl Integrator for Business Analytics
Pl Integrator for Business Analytics A& & &

CAST-INT-CL

Datacenter Demo

0
-

4 [P Data Centers

4 [ Americas

4 [ Atlanta

» ) Colot

» ) Colo2
L —

Attributes

x
—
LT

0O select All

& ColoNumber

 Zonel.Capacity

 Zonel.CapacityPercent

4 Zonel.DCIE

 ZonelPUE

& ZonelPWR

4 ZonelRollingCost

 ZonelStatus

& Zone2 Capacity

4 Zone2 CapacityPercent

 Zone2 DCIE

4 Zone2 PUE

 Zone2 PWR

& Zone2 RollingCost

 Zone2 Status

 Zone3 Capacity

& Zone3 CapacityPercent
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UErE oUEIlE B A8 B2 647) YRl HS0| Qi TS ZTJt EAIELICH YR F0| =EIK0]
XI2HO1: Zones 5 430] B7H T E3HE) BIsHe ZD} obd CHE Qo4 E B8 CHE ZEt0| UBLIC

Select Data > Modify View > Publish

@ Source Assets T Search Shape

T Asset Shape

Server CASTINT-CL v

4 [ Atlanta v
4 ) Colol

& Zone*.Capacity

Database Datacenter Demo oo

@ Assets

N N,

4 [ Data Centers ) s T
one* PW

w,
X X X X X

4 [ Americas
4 () Atlanta
‘ » § Colot
» ) Colo2
» 6 Colo2
» @ Chicago
3 8 Housten

& Zone" RollingCost v

» () New York -

7]

Attributes |

0O select All

& ColoNumber

& Zonel.Capacity

# Zonel CapacityPercent
& Zone!DCIE

& ZonelPUE

& Zonel PWR

& ZonelRollingCost

' 0 000 Qe

Ol ofloll A 127H(47H 2t B0l CHaH 37H) Fo| ofL|2t Z S4doi| CHal &t

| 2
LICH Xp&F SEf EElolM S0l & L=rtE I8 S FTtstod Bsts ZntE ¥ &+ U&LICH OhE A

oA ALEFIE DFL JHE L A GHE HodE LI

1. Xt plote Y ez e SEELIc
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+' Matches
Found 64 Matches
4 (D Atlanta
4 © colot
# Zone4 Capacity
# Zoned PWR
4 Zone4RollingCost
4 @ Atlanta
4 @ colot
# Zone3 Capacity
# ZonedPWR
4 Zone4 RollingCost
4 @ Atlanta
4 @ Colot
4 Zone2 Capacity
# Zone4 PWR
L 4 Zaone4 RollingCost
4 (D Atlanta
4 @ Colot
L 4 Zaonel.Capacity
4 Zoned PWR

# Zone4RollingCost
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Select Data > Modify View > Publish

@ Source Assets T Search Shape + Matches
T, Asset Shape Found 1 Match

Server CASTINT-CL v

4 [ Atlanta

4 (@ Atlanta s

4 @ colol ra

Database Datacenter Demo

[ 4]
“

4 @ Colot

@ Assets

& Zonel.Capacity 4 Zonel.Capacity

W, N,
X X %X x %

4 () Data Cent
&) Data Centers & Zore1PUR # Zonel PWR

- A a
@ Americas # Zoe1RolingCost v # ZonelRollingCost

4 @ Atlanta

‘ » &) Colol

» ) Colo2

» @ Coloz
» fa Chicago
> @ Houston
» @ New York

» fa San Leandro

Attributes | x

0O Select All

4P ColoNumber

4 Zonel.Capacity

& Zonel.CapacityPercent
4 ZonelDCIE

& Zonel.PUE

& ZonelPWR

4 Zonel RollingCost

LI - - T - I - -]
4

N
2

R 2544 (Zonel.Capacity) €0l /= 7 2 Z2/3fLc)
3. TE{ % O3t AXIIM 2T E 285t5ls 2ArYs o

C 2 d’iELuct
| ol M0l A Zone 1€ HE(*) 2 HFELICH

ke
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Edit Filters

# Attribute Name

* Capacity

Pl Integrator for Business Analytics
Pl Integrator for Business Analytics A& & &

Show Wildcard Groups &

Attribute Category

Capacity

(#) Add Filter

Optional Attribute o

© 2015-2025 AVEVA Group Limited and its subsidiaries. All rights reserved.
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Pl Integrator for Business Analytics

Pl Integrator for Business Analytics A& & &

Select Data > Modify View > Publish

(@ Source Assets T Search Shape ' Matches
Server Jp——— . T Asset Shape Found 4 Matches
Database Datacenter Demo oo 9 B ke
4 @ colot £ % 4 @ Colot
@ Assets & * Capacity P & Zone4 Capacity
4 () Data Centers & Zonel PUR Fx # Zone1PWR
4 (@ Americas & ZonetRolingCost Fx # zonelRollingCost
4 [ Atlanta 4 @ Atlanta
| » @ Colot 4 @ Colol
» @ colo2 & Zone3 Capacity
» @ Colo3 # ZonelPWR
» &) Chicago & Zone1RollingCost
» (D Houston 4 @ Atlanta
» B New York 4 @ colol

» San Ls d
@ San Leandro # Zone2 Capacity

# ZonelPWR

4 Zone1RollingCost

4 @ Atlanta
Atributes | x| 4 @ colot
4 ZonelCapacity

O Select Al & Zone1PWR

CenEm e # 7one1 RollingCost

4 Zonel Capacity L]

4 Zonel.CapacityPercent (i ]

# Zonel.DCIE i ]

# Zonel.PUE [ ]

& Zonel PWR (i ]

& Zonel.RollingCost e

= eIl & A (Zonel.PWR) Lol i= ¢ 2 Z gLt
ZEe = s XM 22 EXMY(Zone1) S HEE HHELICH
TE| £ Chst ARHOI CHE =0l EAIEILICH

Edit Filters

Hide Wildcard Groups €
¥ Attribute Name

‘ You've added a wildcard symbol (*) to multiple nodes in the

‘ 1PwR Shape Tree:
Attribute Category # *.Capacity
& PWR

| Power r

Group Together Keep Wildcards

(®) Add Filter

Optional Attribute (i}

Don't show this message again

8 OEsE 2 e ct
LZE = st 4Rt EE = 28 12 HhHELUCH 2
(Group1.Capacity 2! Group1.PWR)O| I A|ElL|C}.

REZ = a5 10 X2 E &Y
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Edit Filters

Hide Wildcard Groups €
¥ Attribute Name Group Name Group Usage
‘ Group 1 & | Group 1 .Capacity
& Group 1 .PWR

| Group 1 x PWR

Attribute Category

‘ Power ¥
(#) Add Filter
Optional Attribute @ {# Create New Wildcard Group

Select Data > Modify View > Publish

@ Source Assets T, Search Shape + Matches
EzmEr CASTANT-CL v T Asset Shape Found 4 Matches
Database Datacenter Demo oo 4 @aventa X k-
4 @ Colot S 4 @ Colot
@ Assets
& [Greup i Capacity £ % & Zone4 Capacity
4 [ Data Centers & [Group'i PwR S % # Zoned PWR
4 @ americas 4 ZonelRollingCost e # ZonetRollingCost
4 8 Atlanta 4 @ Atlanta
‘ » ) Colol 46 Colot
» @ colo2 & Zone3 Capacity
» @ Colo3 # ZonezPWR
» @ chicago # Zone1RollingCost
3 8 Houston 4 @ Atlanta
» ) New York 4 @ Colot
» 6 San Leandro # Zone2 Capacity
# Zone2 PWR
# ZonelRollingCost
- ED Atlanta
Attributes ‘ ® ‘ B
# Zonel.Capacity
0O Select Al # Zone1 PWR
& ColoNumber [: ] # Zone1RollingCost
4 Zonel.Capacity (i ]
P Zonel CapacityPercent [: )
& Zonel.DCIE [:]
& Zonel PUE (i ]
& Zonel PWR [: ]
& ZonelRollingCost ()

10. 35 At (Zone1)S ATAM|IELICEH
QE

11.
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Edit Filters
Hide Wildcard Groups €

me Group Usage

Group 1 \ & Group 1 .Capacity
& Group 1 .PWR

| Attribute Name

|RallinaCost
E\\s Group 1 I
] Attribute Category

‘ Cost

) Add Filter

() Optional Attribute (5] (¥ Create New Wildcard Group (= Delete Wildcard Group

Insert Wildcard Group 1 at cursor position

S 232142 28 19| 4 UEFIER E M 7 §4E EoiFLICH
Edit Filters
Hide Wildcard Groups €
I Attribute Name Group Name Group Usage

‘ Group 1 & Group 1 .Capacity
& Group 1 .PWR
& | Group 1 .RollingCost

| Group 1 % .RollingCost

I Attribute Category

‘ Cost

) Add Filter

[ Optional Attribute @ (# Create New Wildcard Group
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Select Data > Modify View > Publish

@ Source Assets

Server CAST-INT-CL

Database Datacenter Demo

[ 4]

@ Assets
4 e Data Centers
4 @ Americas

4 [ Atlanta

| » @ Colot

» ) Colo2
» ) Colo3
» [ Chicago
r e Houston

» () New York

Attributes |

O select All

4 ColoNumber

4 Zonel.Capacity

4 Zonel.CapacityPercent
# ZonelDCIE

& ZonelPUE

# Zonel PWR

4 Zonel.RollingCost

LI - - -

T Search Shape
. Asset Shape
4 @ Atlanta
4 @ colo
4 Group 1 Capacity
& Group 1 PWR

4 Group 1 RollingCost

NN NN, N,
X X X %X X

Pl Integrator for Business Analytics

Pl Integrator for Business Analytics At 2§

+ Matches
Found 4 Matches
» @ Atlanta
» @ Atlanta
» (@ Atlanta

» (@ Atlanta

O AUEFIEE AFE8H W 7] LX| =2 &7H 2 E3HE! Zonel, Zone2, Zone3 & Zoned EEE EA|

gfLcH
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v Matches

Found 4 Matches
4 @ Atlanta
4 @ Colo
& Zoned Capacity
& Zoned PWR
& Zone4 Rol ngCost
4 @ Atlanta
4 @ Colo
L 4 Zone3.Capacity
# Zone3a PWR
& Zone3 Rol ngCost
4 @ Atlanta
4 @ Colo
L 4 Zone2 Capacity
& Zone2 PWR
4 Zone2 RollingCost
4 @ Atlanta
4 [ colat
L 4 Zonel.Capacity
& ZonelPWR

& ZonelRollingCost

B7|+=d HoOo|X
B7| +Hd o o|X|o|M HIAIXIE ELfE O AR E
2} 0| 7|zt M TIO|E{E M| 2lst T T|O|E|E =

FRIs8 EoiELICH
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A7(0tt HIAIXIE 2 Al7|E RIEELICH B0
Zl(backfil) & = U&LICH CtS AT BIAFS ChFEF Tt
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Select Data > Modify View > Publish Next
T Shapes o’ Message Designer @) Preview @

To Asset Shape Preview Start Time

| Schema Options ” Message Trigger ” Backfill Data ” Message Filters |
4 @ colol S X L ‘
& ColoNu.. & x You@cingyoursch@theasset she@aﬂaﬂeneds@. Preview End Time
OZone‘l.... &S x Import Schema Select Schema Structure ) EI‘
® Zonel.. & x | Select Import Source v| | Sync to Asset Shape (Flattened) v| {
"Colol": "Colol",
®zonel.. & % “ColoNumber™: "1.664574",
"Zonel.Capacity™: "162",
"Zonel.CapacityPercent™: 171.21975703007812,
"Z 1.pcigE™: "38.5215",
{ @ "Tz;:rtam;": "28;5—19—29T31:51:56.869326?-8?:@‘.
"Colol": "[& Colo1 (Name) v, p ‘}[-,
“ColoNumber™: "[4 ColoNumber (Valug) v, & "Colol”: "Colol”,
"ColoMumber™: " Se83",
“Zonel.Capacity™: "|4p Zonel Capacity (Value) v, & “Zonel.Capacity™: "162",
"Zonel.CapacityPercent™: 172.82561950683594,
"Zonel,.CapacityPercent”: "|0Zone1.CapacityF'ercent{Value] A\ "Zonel.DCiE™: "37.82698",
"Timestamp”: “2018-18-29T@1:52:56.8603267-87:0¢
“Zonel.DCiE": |4 ZonelDCIE (Value) v, Vi 1
"Timestamp”: "|® TimeStamp v 4 ¢ "Colol": "c:l:.l",
"ColoNumber™: "1. 85"
3 "Zonel. Capac1ty 62"
"Zonel. Capac1tyPE| cent”: 173.2198944891797,
"Zonel.DCiE": "37.5575
"Timestamp": "2815 18-29T@1:53:56.8603267-87:8¢
‘}[-,
"Colol": "Colol",
"ColoMumber™: "1.67812",
© Add Property to Schema "Zonel.Capacity™: "182",
"FTrnael FanarituPercent™: 177 TA?IRIAARACARRR
PN} k=
1 RhoH HE - "Ejo| @ 4 3 &2 HIAIX| CIRto|L
do|A7ot EYez Zojct =2 + JU&LICH
2 HAIX| CIXtO|LA - O] oAM= A7|0HE MEst T,
HAIX| EB|HE XIHst L, £7|0F §EE +=Hst
o, olojelg H—'.*-‘_g'(backﬁll).%."l—m'.
3 0|2l 27| - HIAIX| C|XFO|L] B ofl ZAIE AF7|0F &
Ao 2 X2 100702 HIAIX|E FEAIELICH
4 A7|0F- HAIRIE ELHE Ol AFEE AF|0IE EA|
guict
5 70t M- HAIXIE ELHE Ol AFSE A 7(0HE
MEHSFLICH KHAF ZElof ket e & AF|0HE A
Eot7Lt ot E= BX|AEEo|M A7|0HE 7HA
2 7 AL
6 7|0t §EE AL, 7|0 §EHe =ME
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7tK2
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= oy
A5 HL, AF7|0F EME AN LICH A7|OF &
ol ek AF2 & = e SM0| UELICH

7 HIAIR| EE|H - HIA| CHArO HIAIR|E ELiE BIE
2 XHE X[HELCH

8 HHZl(Backfill) Gl O|E] - HIA| CHALO| Wl 0|7 ghe
X~k

9 HIAIX| 2E - M|l o|o|E] ZutE X|™FHELICH.

H

71 4% HOIXIoIA &1 BrRsHe Yol CHE RS LIS S Che 2 &

FAAIL.

oll

oo M 7kM 2 A 7|0 AL
7|0t HIR[AEE[M 7HK2 AF7(0F AHS
MMEE AT|OALE
HIAIXIE 2L i 4.
8 2 (hackfill) & O|E]

=t
=

1: O] 7|52 Pl Integrator for Business Analytics 12 OIC|A0| M AFE & &~ Ql&LICt

Tl o R HEf e 222 HAIX|O CHEt A7|0HE M&IsHs Ol ASEILICH Ol MaE A
7|0+E AFSHHLE A7|0HE 7HR4E 4 /o™ Hel HlolE] Zhol A7|otoll & ELIC

A7|Of

AZ

[=]

t= ZtUOo|Lt A 7|0 B R[AEE[0|M 7k &8 & U&LICH

El

FRIO M 7FK{= A 7|0} - JSON(JavaScript Object Notation), CSV(&EZ T2 & 2f) ! Apache Avro2t Z
Ao AF|obE UMM 7HKAE &= JU&ELICH 71X 7|7F BLUH Sdof| 22 st SH2
ZEhct

A7|0FHIRAEZ|HM 7HK2 A 7|0} - O] 2I2|A = Apache Avro 2 7|0HE AF& SH= Confluent A 7|0
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loT 0'|E, Google Cloud Storage, Google & &/7 =, Hadoop E4F I Y HE A LU EIAE U SO|CHa
of M8 x|X| &&L/Ct.

A o|Fo HAI2 Z o ME Ao MEto et CHAl XI™HELICH o|& S04, Oracle & OIF 2 30Kt 2
MNEHz|H 30XHECH 71 & O|&§ 2 A ELCE.
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#H4 gf S gretghuct.

@ Column Details

MName

Forecasted Chance of Rain |

Reset Name to Default

Data Content 9

VEINT v |

Data Type

Double v |

Remove

Apply Changes
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2 S2Mo 2 EA|T|K| et& Lt
Row Filters X
Add New Row Filter
String Include rows based on whether the contents of a column match a
string pattern
Diqita Include rows based on whether the contents of a column contain
_ certain digital values
NUmeric Include rows based on whether the contents of a column contain
certain numeric values
Null Values Include rows where the contents of a column contain a value
Event Frame Include rows where certain Event Frames are active
Close
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EHE Ol E7|o ME& m O|HE =] Zent LUx|ste &=l AHMES HM5t= O|HE HEfS Mo
gHLICH 2124™ Plintegrator0ll M 28 AHE J7|E 2 2 5104 0|28t & HIME HAZA5lo F ZHMat &

x|5tE CllolE 2| ot 2l
ol &

M #E#t Co|EE 7|55
Lict o|HIE =@
o 2loi| CHet A&t 27| CIO[HE =

M=
o=

= |:|:| |:|.E -9—JIO.||

© 2015-2025 AVEVA Group Limited and its subsidiaries. All rights reserved.

Sof, S THI7} 2t Loll M Bt ol shLtA

e e d&Lch

A= ol o4 7H 1, o|HIE = Bf|lo] o] ZH|of
= fj|otch A|ZF AlZEDE S F AlZHO| C}
HI7F SHE oA AISEl 7| ZHol| CHEH A

ot= Ol AF8EICh T 7HggrLICt o] |E

ile 3 TElS 3

Page 162



AV=VA"

Pl Integrator for Business Analytics
Pl Integrator for Business Analytics A& & &

LT ER Y

1. My Views HO|X|0M =H3lE{= E7 = S =
0 27| = m|o|X|& ¥LIct
Zt 7. 27| £ Ho|x[of 00| /= AL CF2 Bl 2 HE LCH
2. AMEF AL SE AZHEES AP%ﬂO# Hets O|HE ZYo| 7ISE AlZhE Z&SHES AlZh He
£ =Yg
23 AR U B2 AZHo| OJfIE T Azt H9IE oLt B9 O¥E Z3Y2 &8 + giaL
ct.
3. HEE Y2 225t TE| R0 e OHE =i M=EhL|Ct
O|A| Pl Integrator0| A= PI AF Cl|O|E{H|O| A0 A O] EZ]of| CHEH O|HE =2 HAMSI T sk 0]
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Create New Event Frame Row Filter
Event Frames _ Shape Tree
4 () Catalytic Cracking
et Eert Ererme from e Event Erames Baletie here 4 () Boiler-210
» " Casing Temperature Excursion Roc ST S - A R
» ' Casing Temperature Excursion Roc @ Fuel Gas Flow
» " Casing Temperature Excursion Roc & Fuel Gas Volume
» "d Casing Temperature Excursion Roc
» "§ Casing Temperature Excursion Roc
» "§ Casing Temperature Excursion Roc
» ¥4 Casing Temperature Excursion Rog
» "4 Casing Temperature Excursion Roc
» "4 Casing Temperature Excursion Roc
» " Casing Temperature Excursion Roc ™
Event Frame Related Asset Start Time El
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ZE2 Y=of OJHE Za|ol YIS 8 DiHHAE X|stol Mot OlHE ZaiUg FaLIDH
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Event Frames

Y

Event Name

Event Template

Clear All Filters Apply Filters

Create New Event Frame Row Filter

v S [ Y | ‘ Include rows with this Event Frame Active
matches |EventFrameAnalysis 20150612 01:45:32 XV
Event Name

t is any. Drag an element from the Shape Tree to specify.

p» "H EventFrameAnalysis 20150612 01:46:32

Event Categories
» "8 EventFrameAnalysis 20150612 01:46:32 - AUTCYEnTCeamoh

» H§ EventFrameAnalysis 20150612 01:46:32
» Y@ EventFrameAnalysis 20150612 01:46:32
» BH FuantFramaAnalsis 2MR0R19 04632
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